A few months ago, our PDP10 Model 1095 ( pictured ) had just successfully booted the WAITS operating system and was running an early version of Ethernet.  One afternoon, the PDP11-40 front-end computer ( unit with chassis extended on left ) stopped working and I was tasked to find out what had happened and repair it.  What followed was almost three months of difficult troubleshooting and repair.

What had happened was, one of the peripheral devices ( a TC-11 DECTAPE Controller at the left end of the machine )  attached to the PDP11’s Unibus had had a power supply failure, causing the regulated 15 volt supply to rise to 28 volts.  These supplies have an over-voltage crowbar circuit which is designed to shutdown the supply by blowing a fuse if the power supply ever goes into an over-voltage condition.  This crowbar circuit failed and this resulted in a number of circuit boards in the PDP11 frying.

Once I replaced and/or repaired the failed circuit boards, I upgraded the TC-11 power supply to a modern switcher which doesn’t have the failure mode described above.

With the hardware sorted out ( this is a couple of weeks into troubleshooting ),  I set about trying to boot the WAITS operating system once again.  A further snag cropped up at this point.  WAITS wouldn’t fully start and would complain about a “pointer mismatch”.  This points to the DTE-20 10-11 interface, but no combination of replacement boards would succeed in bringing up WAITS ( except for a number of random times ).  The solution to this problem turned out to be an old bugaboo of the KL-10 processor.  A number of the control devices do not fully initialize at power-on as their reset lines do not go to all of the parts in a particular device.  We have seen this phenomena on the RH-20, but apparently the DTE-20 also has some hardware that doesn’t get initialized.  I determined this by running the -10 side diagnostic for the DTE-20, and then booting WAITS successfully.  This was after weeks of eliminating all other possibilities as myself and others were not aware that the DTE-20 had components that came up in an unknown state at power-on.

One side note: In upgrading the TC-11 power supply, it was found that the power controller that feed line voltage to it, had failed some time ago and been hacked to make it work without it’s contactor.  A new contactor was ordered and installed.